Read Radio Button - Surface Automation

RDawson9

Geek
Staff member
#2
Hi Naga,

Have you read the Blue Prism Surface Automation training guide?

https://portal.blueprism.com

Learning > Surface Automation > "Training Document - Surface Automation (v5)"

There's a section in there purely based around radio buttons and check boxes.

Regards
Rob
 
#3
Hi Rob,

This is the same document i am following currently. That is only giving me what regions should i use but did not mention how to read like what steps to do in order to get whether radio button is checked or not.

Regards,
Naga
 

RDawson9

Geek
Staff member
#4
Hi Naga,

If you take two snapshots - one of the button checked and one of the button empty, you can then use a Wait Stage to determine whether the button is checked or not.

Rob
 
#5
I have 2 different elements. Male - Checked and Male - Unchecked. I am reading this element in Read stage, then selected 'Get Checked'. The flag is returning false in both cases.

Naga
 

RDawson9

Geek
Staff member
#8
Thanks Naga,

Do those elements contain an attribute named "Checked"? If they don't, then "Get Checked" won't work. I suspect they won't as they're radio buttons. I think the "Checked" attribute is only associated with Checkboxes.

Give my suggestion a try and see if that suits what you're trying to do. You could set a Flag to be True or False depending on which element is found.

Rob
 
#9
Thanks Rob,

I identified two radio buttons Male and Female using region mode. Similarly check box of verified using region mode. It is identifying as a button but not radio button or check box. Hence I do not have an attribute name 'Checked?'. How can I identify them such that I get 'Checked?' attribute name?

Regards,
Naga
 

adebroise

RPA Ninja
Staff member
#10
@Naga Mounika Gella it looks to me like you've spied the checkboxes using traditional spying methods (eg. Win32 mode) rather than surface automation. Surface automation uses regions to handle the screen as images.

I'd review the Surface Automation guides on the portal to complete the exercises and ensure you're using regions and the Image Manipulation VBO.
 
#12
@adebroise Thank you. I used surface automation guides from the portal. They asked to take different screen shots for male checked and female checked radio buttons. Thats why I used spied using region mode and not win 32 or AA mode. Please find the screenshot of my male checked element. SA-Male Checked png.png
 
#13
@cs.andras Thank you. But I am trying to find a solution without using image search. I have an option called "uniform colour" in my wait stage to check whether region has uniform colour or not.

Learning > Surface Automation > "Training Document - Surface Automation Advanced Training(v6)" - Page 10

I used the above document from portal which tells me to use uniform colour but it is not working for me while I am using version 5.

Learning > Surface Automation > "Training Document - Surface Automation (v5)" - Page 20

I used the above document from portal which tells me to use separate screenshots for the radio buttons but does not provide complete information how to do it.

Can you please help me in steps how to use 'uniform colour' of my wait stage for a region such that i can use uniform colour concept to distinguish?

Thanks in advance.

Regards,
Naga Mounika Gella
 
#14
Hi, did you get the answer on how to check if the check box / radio button is Clicked or not ?
I'm looking for the same. Could not find more info or no one seems to know it thoroughly. Please help ? Do u have any samples
 
#16
Hello Guys any solution for the current issue as i am also facing same issue with Exercise 2.1.2 in advanced surface automation training course V6.0 i am entirely not sure which logic to apply so please can anyone help thanks in advcance
 
Top